0
Under review

InteractBuilder 4.0.2 Build 381conversion

Jen Hoyte 6 years ago updated by Alin Alexandru Matei 6 years ago 7
Hello.  Ok so I have 4.0,2 version 381.  Opened an app created in version 3.  Said it was converting it.  When I click Interact, it opens it up in Explorer.
  However, the Page Load action does not work, wherever I click with the mouse, a little white circle shows up, and I cannot type into a text box.  Actually, looks as though no actions work.
Are there any touchups we need to do after the conversion?
Incidentally, I just re-created the first few pages from scratch.  Same thing happens.  Plus when I clickInteract, it just goes to a particular page which is not the first page.

Answer

Answer
Under review
Hi Jen,
The white circle is just part of the way the app displays in browsers to signal that you have clicked an area, but the other two problems that you reported shouldn't need touch-ups. Did you have Explorer as your default browser when you tested the app in previous versions of InteractBuilder? We do suggest testing the apps with Google Chrome since InteractBuilder is optimized for this browser. Here are instructions on setting Google Chrome to be your default browser in case you're interested: How to Preview an App.
Answer
Under review
Hi Jen,
The white circle is just part of the way the app displays in browsers to signal that you have clicked an area, but the other two problems that you reported shouldn't need touch-ups. Did you have Explorer as your default browser when you tested the app in previous versions of InteractBuilder? We do suggest testing the apps with Google Chrome since InteractBuilder is optimized for this browser. Here are instructions on setting Google Chrome to be your default browser in case you're interested: How to Preview an App.
Thanks.  Making headway.  ok actions working better.  But still can't type into the text fields which are being triggered by a Tap to prompt for text..
Also, another action is supposed to show a box at layer 1, with graphics on top at higher layers.  It only shows half the graphics.
Jen, for the text fields, you need to have at least a transparent graphic element (on top of the text field) that will trigger the Tap-SetText for the text field.
For the second situation with the box, could you recreate this on a one page app upload it do Dropbox or any other sharing site and send it over to alin@interactstudios.com, and we will take a look at this. Thank you for your feedback. 
Thanks.  I got this to work by using the transparent element and i have emailed the one page app.  I was able to figure out the Page Load action issue.
Did you send the sample app to alin@interactstudios.com? I didn't get it so far.
ok I have sent you the sample app with the white square on a non-white background.  Everything else in my original question on this thread is now taken care of.  Thanks.
Ok thank you Jen, got your email.