0
Started

Chaining Behavior Bugs - Can't chain On Tap to an On Load Interaction

Charmaine Anderson 7 ár síðan updated by Ezra Weinstein (Administrator) 7 ár síðan 1

Problem:
Can’t Chain an On Tap interaction to an On Load Interaction in Manage Action Sets screen.


Desired behavior: 
I want to make an animated element fly into place on page load.  Then I
want  the element On Tap to go to a new
location and fly off screen and fade out or be hidden so it doesn’t take up
processing resources on end user system.  This seems like such a simple thing to do.... if there is an easier way, please advise!


Steps to Reproduce:  (Use PC version of IB3)

In Element Manager:

1. Action set applied to an animated .png sequence element: 
Interaction > None > Animate on Page Load, Transition > coordinates set.

Result: In Interact Mode, the Element flies into desired place and stops as expected.  No problem here. Issue occurs in next step.

2. Another Action Set is a applied to same element:

On Tap > Animate > Transition to a new location on the stage.

Result:
In Interact Mode, the On Tap, the Element jumps back to original
position
on the stage and moves to the desired location off screen. 

Expectation:  Need the element to remember where it was on stage when it is tapped and not jump back to original location.  When I view the object transition settings in the Manage Action Sets screen and click on the behavior and select Change, the elements target location is set to “ , “ and won’t let me change the current coordinates for the element. 

In Manage Action Sets Screen:

I tried chaining the 2nd On Tap Action Set noted above to the parent
On Load , but then the On TAP interaction changes to
None, resulting in not being able to make the element move from its first
location to the desired new location. 
Expectation is the On Tap behavior should be able to be chained to the
parent  On Page Load behavior.


Another Bug noticed:

The Transition settings of chained behavior does not appear in the Element Manager when applied from the Manage Action Sets Screen. 
I set the Transition coordinates using the Change option in the Manage Action Sets screen and when I view them the Action set within the Element Manager, it shows the transition as not being set, None
is still checked.
  (Expectation is to see the settings displayed that were set within Manage Action Sets.)


Also, Need to know the best Way to Delete Element from
screen after a transition ends?

When Element moves off screen, I want to delete it from the stage so it doesn’t take up computing resources on end users system. (Not sure if simply setting visibility to none or hiding the element frees up processing power on end users tablet?)  I tried chaining a Hide Element to a previous transition behavior and this doesn’t work either.


I then tried chaining the On Tap Fade out behavior and got this
Errror message: (Fade out doesn’t work either).


InteractBuilder
Version: 3.1 Build 306



Device: VPCL138FX



Processor: 1
Processor(s) Installed.



[01]: Intel64 Family 6
Model 23 Stepping 10 GenuineIntel ~2670 Mhz



Memory: 8,127 MB



System: NT 6.1


--------------------



An application error
occurred while attempting to perform the last action.


Restarting
InteractBuilder is recommended.


An application error
occurred while attempting to perform the last action.


Restarting
InteractBuilder is recommended.


Error: Operators div:
divide by zero / put: error in expression



Handler: Behavior_Fade



Hint:



Location: Line 4039,
char 26



Object: button id 1008
of group id 1010 of card id 1002 of stack "Behaviors" of stack
"C:/Program Files (x86)/InteractBuilder/Local Components/Data/InteractBuilder.livecode"


159: Line 4039 at char
26: Operators div: divide by zero



465: Line 4039 at char
1: put: error in expression



253: Line 4034 at char
1: if-then: error in statement



253: Line 4031 at char
1: if-then: error in statement



587: Line 4007 at char
1: switch: error in statement



253: Line 4004 at char
1: if-then: error in statement



253: Line 4003 at char
1: if-then: error in statement



241: Line 4003 at char
1: Handler: error in statement ----> Behavior_Fade



353: Line 0 at char 0:
Object Name: ----> button id 1008 of group id 1010 of card id 1002 of stack
"Behaviors" of stack "C:/Program Files
(x86)/InteractBuilder/Local Components/Data/InteractBuilder.livecode"



675: Line 2397 at char
1:  ----> Behavior_Fade



587: Line 2317 at char
1: switch: error in statement



253: Line 2299 at char
1: if-then: error in statement



253: Line 2296 at char
1: if-then: error in statement



253: Line 2262 at char
1: if-then: error in statement



241: Line 2262 at char
1: Handler: error in statement ----> _Behavior_Do



353: Line 0 at char 0:
Object Name: ----> button id 1008 of group id 1010 of card id 1002 of stack
"Behaviors" of stack "C:/Program Files
(x86)/InteractBuilder/Local Components/Data/InteractBuilder.livecode"



573: Line 1754 at char
1: Handler: can't find handler ----> _Behavior_Do



253: Line 1753 at char
1: if-then: error in statement



587: Line 1748 at char
1: switch: error in statement



490: Line 1738 at char
1: repeat: error in statement



490: Line 1735 at char
1: repeat: error in statement



241: Line 1735 at char
1: Handler: error in statement ----> _Interaction_Do



353: Line 0 at char 0:
Object Name: ----> button id 1008 of group id 1010 of card id 1002 of stack
"Behaviors" of stack "C:/Program Files
(x86)/InteractBuilder/Local Components/Data/InteractBuilder.livecode"



573: Line 1697 at char
1: Handler: can't find handler ----> _Interaction_Do



241: Line 1697 at char
1: Handler: error in statement ----> Interaction_Tap



353: Line 0 at char 0:
Object Name: ----> button id 1008 of group id 1010 of card id 1002 of stack
"Behaviors" of stack "C:/Program Files
(x86)/InteractBuilder/Local Components/Data/InteractBuilder.livecode"



675: Line 754 at char
1:  ----> Interaction_Tap



587: Line 715 at char
1: switch: error in statement



253: Line 711 at char
1: if-then: error in statement



253: Line 684 at char
1: if-then: error in statement



241: Line 684 at char
1: Handler: error in statement ----> Element_MouseDown



353: Line 0 at char 0:
Object Name: ----> button id 1008 of group id 1010 of card id 1002 of stack
"Behaviors" of stack "C:/Program Files
(x86)/InteractBuilder/Local Components/Data/InteractBuilder.livecode"



573: Line 36 at char
1: Handler: can't find handler ----> Element_MouseDown



253: Line 35 at char
1: if-then: error in statement



241: Line 35 at char
1: Handler: error in statement ----> mouseDown



353: Line 0 at char 0:
Object Name: ----> button id 1066 of card id 1002 of stack
"IBElements" of stack "C:/Program Files
(x86)/InteractBuilder/Local Components/Data/InteractBuilder.livecode"


button id 1299 of card
id 1002 of stack "libSTSErrors" of stack "C:/Program Files
(x86)/InteractBuilder/Local
Components/Data/InteractBuilder.livecode",errorDialog,150



stack "C:/Program
Files (x86)/InteractBuilder/Local
Components/Data/InteractBuilder.livecode",DoError,10513,button id 1004 of
card id 1002 of stack "Behaviors" of stack "C:/Program Files
(x86)/InteractBuilder/Local Components/Data/InteractBuilder.livecode"




Answer

Answer
Started

Hi Charmaine,


The first issue you reported is a bug.  Please enter your issues into separate feedback comments so we can better manage each bug and request properly.


I was able to properly hide an element after a transition animation but not if the transition ran on Page Load.


The problem with setting the transition animation type in the Element Manager is also a bug.


Thanks,


Ezra

Answer
Started

Hi Charmaine,


The first issue you reported is a bug.  Please enter your issues into separate feedback comments so we can better manage each bug and request properly.


I was able to properly hide an element after a transition animation but not if the transition ran on Page Load.


The problem with setting the transition animation type in the Element Manager is also a bug.


Thanks,


Ezra