Trouble viewing app in Interact mode in IB4

Gabrielle Strouse hace 10 años actualizado por Ezra Weinstein (Administrator) hace 10 años 21
I have searched the forum, and haven't found anyone explaining the step I seem to be missing.  I click "Interact" in V4 and choose "all" and I see the status bar go to 100% and interactplayer.com comes up in my web browser.  I log in, and I see the cover photo for my app.  I click it, and nothing happens.  None of the actions in the dropdown menu seem to lead me toward the preview.  What do I do to actually preview the app?  I have tried in Chrome and IE.

Updated to the Bug category after comparing with another one of my apps.  The other one gives me a solid black screen when I click on its icon on interactplayer.com.

So I can view neither app.  Please advise!
En revisión
Hi Gabrielle, it's an app created in IB4 or it's an app created in IB3? If your app was created in IB3, did you see by any chance if the conversion process was successfully. ( This process should have occurred when you opened your app first time in IB4.)
Hi Alin,

Both apps were built in IB3. For the first one, the first time I opened it I think it converted successfully, however it did not completely upload the first time I pushed "Interact." My computer ran out of power before it completed.  So I needed to restart and press "Interact" again for it to upload fully.  For the second app, I believe it converted and uploaded successfully.

Starting in the last few minutes, the first app has disappeared completely from the interactplayer website.  The other app gives me only a black screen when I click it.

For what it's worth, there are three apps down at the bottom under "member apps shared with you." When I click one of these, it prompts me to log in and brings me back to the list of apps.  This is an endless cycle.

Thanks for your help.

I just tried to use IE instead of Chrome but it says I already have 3 devices so won't let me login.
In the application folder do you have a player folder?
Yes.  All my images are in the graphics folder and there is a json for each page.
To check if there is any specific feature that is preventing the apps from opening, could you create a one-page app with one graphic element in it and see if it opens in InteractPlayer? This should help us start to isolate the problem.
Yes, the test app works.
Gabrielle could you try this:
1)Move your app from Interactbuilder folder.
2)Make a copy of it.
3)Give the copy a different name.
4)Move the copy of your app in Interactbuilder folder.
5)Open it in Interactbuilder.
6)Try to open it in InteractMode.
Hi Alin. After following those steps, the new app said "Syncing with server," with no errors.  It opened the login page. I logged in, but the app does not appear in the list.

Hi Gabrielle,
We're finding that there are certain features that are preventing apps from loading in InteractBuilder, and the developers are working on resolving this. If an app has intersections it may run into a problem in Interact mode. Hopefully the app will load when the next update is available. If not, just let us know, and we'll look into which other effects may be causing the problem.
Inna, I'm only using intersections on 3 of the pages.  Is there a way to test the other parts of the book?  And do you have an expected release date for the next version (like, on a timescale of days, weeks, or months)?
If you ask the app to preview just one page after clicking "Interact," does the app still not show in InteractPlayer.com?
That's correct.  Even on a page with only 1 image and some text, when I click "Interact" it takes me to the list of apps and mine is not listed.
Gabrielle, I would recommend that you log out of the InteractBuilder and Login again.  To log out of the InteractBuilder follow the directions here:

1. Go to the Manage Screen (the one with the bookcase)
2. Tap the icon of the person on the upper right hand corner of the screen
3. Choose the option "Login as someone else"
4. Login using the same credentials you are using to access the InteractPlayer site
5. Create a quick test app and click Interact

Let us know your results.

Hi Ezra, After logging back in, nothing changed with regard to my book.  

However, I had made a copy of it a while back in version 3, and I placed this copy in the InteractBuilder folder. IB4 then converted it to version 4 and I am able to see some of this one -- just the first few pages up until the first page with Intersections.  When I try to load that page on it's own, it just sticks on the loading screen.  So I suppose I need to wait for an update to get past this?

In the mean time, I suppose I will need to use my v3 files and open them in IB3 on a different computer in order to make changes and continue using the book.  If I do this, will I be able to share the book to push it out to my tablet device as I have always done in version 3? 
For now, we've gotten rid of the IB3 sharing feature, so you can preview the app in IB3 Interact mode to test the interactions.
So you're saying that right now my book does not work in IB4, there's nothing I can do about that, and I cannot use IB3 to make updates?  I am using these books for an ongoing research study and I need to be able to make edits. 
You can use InteractBuilder 3 to make updates to the app. If you prefer to continue to work on it in IB3 before we resolve the problem in IB4, then you can edit the app in IB3 and preview it in Interact mode.
Gabrielle you can view your app in IB4 InteractMode. We had a problem with pages that have Intersections on them which will be fixed in the coming update.
Yes, but I need to be able to make edits and actually run them with research participants, not just preview them.  I am looking forward to your update and hope it comes very soon.