0
Under vurdering

Page turn default behaviour not working

Paul Snakes 6 år siden opdateret 6 år siden 6
Hi

I am testing my apps on the interact mode online; but when I tap on the right / left corners to go to the next / previous page, it doesn’t work! I know page turn effects (e.g Page curl) doesn’t work currently; and therefore I disabled them on my App settings, but now, the page turn default behaviour when tapping on corners doesn’t work.

I wonder if it is because I have an object in such places (an image with a circle marking where the user has to tap), but on version 3.3 this wasn’t an issue. Should I place global - invisible elements on top of the corners with the “go to next / previous page” behaviour on them? or am I missing something?

I ask you about the global element because I read that these are having some issues also; so I wonder if these is the best workaround..

thanks,
Pablo

Svar

Svar
Under vurdering
Hi Pablo,
The default page corners should still be working. And objects in the corners actually shouldn't affect them, because the page turn area is in front of all other elements. When you preview the app, are you selecting multiple pages to preview, not only the current page? In each page's "Features" tab, do you have "disable page flip backwards" and "disable page flip forwards" set to "no?"
Svar
Under vurdering
Hi Pablo,
The default page corners should still be working. And objects in the corners actually shouldn't affect them, because the page turn area is in front of all other elements. When you preview the app, are you selecting multiple pages to preview, not only the current page? In each page's "Features" tab, do you have "disable page flip backwards" and "disable page flip forwards" set to "no?"
Hi Inna! I think I have found where the problem was: I did have "disable page flip backwards / forwards" set to "no"; but the "Page Turn Effects" option ( in the same menu of page settings > features) I had set "Use app default". Now, I had the Page turn effect disabled for the whole app in App properties settings; I guess this caused some sort of conflict. I just set "Page Turn Effects" to "none" also in the page settings of some pages... then deleted the graphic elements I had put on the corners; and I found it did work! interestingly, it worked on every page, even though I had set the "Page turn effect" to none just on three pages of my app... but I'll tweak it on every page, just in case ; )

thanks,
Pablo

Interesting! Thank you for pointing this out. I'll test out the problem and report it to our lead developer. I'm glad you found a way to fix it for your app!
Hi Inna! bad news: the problem persists. Currently page turn default behaviour on the corners of each page is not working anymore, even though I set on every page settings > features "Page turn effects --> none" and that "Disable page flip backwards / forwards" is set to "no".

Appart form this there is another intriguing problem going on on page 2 of my app: when tapping over "Castellano" or "English"; there is a message that appears on the upper part that should only appear when tapping an invisible object set in this area; but that has nothing to do with "Castellano" or "English" objects, neither it is overlapping them. This doesn't happen when tapping over "Galego" option; when only the stuff on the bottom of the page appears, as expected. 

I am a bit worry about this problem, because when we had sent the app to Apple for approval back in April, they had rejected it due to problems in this page 2. This page is where a couple of global elements are introduced to manage language change on every page of the book. This language update has always worked fine on every single page, and I don't know why the Apple team found problems on this page. But now, I wonder wether this curious phenomenom of the upper text appearing has something to do with it...

I can send you the app folder if you want to see it closely... it's important to me have this apps finally published on the AppStore.

thanks
Pablo
Yes, you can email the app to inna@interactstudios.com, and I'll see if I can find what might be causing the problems.
I've just sent it through.. thank you!

Kundesupport af UserEcho